Forum

HomeHomeCoreCoreGeneralGeneralXML Query not TransformingXML Query not Transforming
Previous
 
Next
New Post
1/16/2012 7:47 AM
 
Here is my Query Action:


--------------

<XML>

 <PATH>http://[IP]/ServiceName.asmx/GetVehicleList</PATH>

 <GET>

 <CONTENTTYPE>text/xml</CONTENTTYPE

<QUERY>make=toyota&model=camry&startyear=2008&endyear=2010&zip=60532&distance=10&lowprice=0&highprice=50000&page=1&pagesize=10</QUERY>

 </GET>

 <NAMESPACES> <NAMESPACE><URI></URI><PREFIX></PREFIX></NAMESPACE> </NAMESPACES>

 <TRANSFORM><SOURCE>Vehicles</SOURCE></TRANSFORM>

</XML>

--------------


This returns 3 tables - "VehicleList" (xml root), "Vehicles" (child of VehicleList), and "VehicleItem" (10 children of Vehicles).

It doesn't matter what I put in for the transform source, I still get those 3 tables in my debug output. 

If I put in anything for <ROW> and <COLUMN>, I get the table "Table1" with 0 rows and 0 columns.


Is there anything wrong with my input?

Alternatively, is there a way to target a different table than the first when I'm looping through results in the query child action?

New Post
3/23/2017 5:03 PM
 
I know it's old but I'm having the same problem.
Impossible to fix as now I think all the XML/JSON etc examples are all broken so no reference material at all.
Most written reference seem to be mainly about SOAP.
Previous
 
Next
HomeHomeCoreCoreGeneralGeneralXML Query not TransformingXML Query not Transforming


 

New York, NY • Baltimore, MD • Vienna, VA • St. Louis, MO • Seattle, WA • 410.327.0007 • info@R2Integrated.com

Bookmark & Share Bookmark and Share